PS4 : I can't download episode 4

I bought the game season pass for quite some time (years), and I finally decided to start to play last month, I play on a PS4.
So, I did the first episode, then decided to download all the episodes for future convenance. So, I was able to download episode 2, 3, and wasn't able to download episode 4, it's like there is no link.
Downloading episode 5 is ok though.
Have you any idea if there is something I can do ?
Thanks in advance.


  • Greetings! Sorry to see that it's been a few days since you uploaded this post. If it is still not resolved, I hope that I can help now!

    I had a similar issue, but it didn't involve the PS store. But I thought of various methods that could help with your issue.

    • Have you tried anything to resolve this issue since posting this? Did you try restarting your PS4?

    [Faites-moi savoir si vous avez besoin de meilleures explications. Je ne connais pas le français (j'utilise Google Translate pour cet article), mais je peux faire de mon mieux pour l'expliquer pour une meilleure compréhension.]

    Try these various different methods (NOT a step by step list) Let me know if they were able to help, or if these options weren't able to work out.

    - Have you tried restoring your Licenses? Select Settings, go to PSN, and find "Restore Licenses." See if anything changes.
    - Go to the Library of your PS4, click the Batman game, scroll to the bottom and select "My Add-Ons", click on the down arrow next to the bundle icon.
    - Click on the Episode that you want to download, if it fails to connect, then click one of the other Episodes (it will probably fail too), then go back to the one you want. Repeat this over, and over, try to see if it'll eventually work after a series of tries.

    PS Store
    - Delete the Add-On of Episode 4, then go to the PS Store. Search up Batman Telltale, on the Store Page -> go to the Add-Ons list, then proceed to download the Episode you want. It should be able to show up on that list! If this is what you did in the picture, then refer to the other methods!
    - If you have the PlayStation App, then try to see if you can download the Episode from the Game Page's Add-Ons, from your phone onto your PS4. (Search in Games [or search Episode number, if that works], click Add-Ons, Download to Console.)

    - Have you tried downloading the episode form the in-game Episodes Menu? Try that, if you haven't.

    If any of the above did not work, then refer to these methods of resolving your issue. The only reason why I separated these from the upper, is that these methods may take up more of your time.

    • The first thing that I'd say, is that to try to delete the Application (+ the Add-Ons as well), and attempt to redownload the game itself, then download the Episodes. But if you already did this (and didn't reset PS4, then try that. If that doesn't work, then refer to the second and last method below.)
    • If you are seeing "Purchased but not Downloaded" in-game for Episode 4 (if you were able to select download, taken to the PS Store so you can download it from there, but if it says that it is already installed, then try what I am about to say.) The issue may resolve if you boot your PS4 into Safe Mode, and select the option "Rebuild Database." After restarted, you should be able to see that Episode 4 is able to be selected and played.

    Let me know if any of these methods were able to help, or if these options didn't work out for you. Will wait kindly for your response or any updates.

    Kind regards,
    Migsby. :)

  • Thank you very much Migsby, I will try all this as soon as possible. :)

  • You are very welcome!! I wish you luck!

    Alizarine posted: »

    Thank you very much Migsby, I will try all this as soon as possible.

  • Hey bro any updates, i’m also facing the same issue. Did it help fix your problem

    Alizarine posted: »

    Thank you very much Migsby, I will try all this as soon as possible.

  • Need help too

  • Hello. I've the same problem. I tried all the methods, without success. Is it a problem from PS store?

  • Same problem here (except I am on PS5). It's frustrating it still hasn't been fixed and people still have this bug

Sign in to comment in this discussion.